Resolve iCloud Sync Issues

Symptom

Macs set up to log in with iCloud credentials aren't synchronized when the JumpCloud password is reset.

Cause

The JumpCloud agent maintains synchronization with local computer accounts. It doesn't currently support iCloud accounts.

Resolution

To ensure that JumpCloud is managing the credentials for a system, disable iCloud account credential synchronization.

Note:

iCloud account credential synchronization is set to off by default in Ventura.

To disable iCloud account credential synchronization on Ventura:

  1. Click on the Apple Menu and choose System Settings…
  2. Double-click Users & Groups
  3. Click the ( i ) next to the desired user.
  4. Toggle Allow user to reset password using Apple ID to off.

To disable iCloud account credential synchronization on earlier macOS versions:

  1. Click on the Apple Menu and choose System Preferences….
  2. In System Preferences, double-click Users & Groups.
  3. In Users & Groups, click the padlock at the bottom-left to allow for configuration changes.
  4. Click the user from the top-left pane, and click Change Password.
  5. At this point you will receive a dialog; if it notes “[User]”  is using an iCloud password to log in and unlock the screen. this confirms that an iCloud account is attached.
  6. Click Use Separate Password….
  7. The user will be required to enter in their iCloud password, along with their JumpCloud password in the New Password field
  8. Once the fields are filled out, click Use Separate Password.

Note:

JumpCloud doesn't impact additional iCloud features such as Photos, Mail, Contacts, Calendars, Safari, Keychain, and Find my Mac. 

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